Service Outage - SnapStream Email Alerts
Incident Report for SnapStream Media
Resolved
All impacted services have been restored. We appreciate your patience. If you are still experiecing issues please reach out to our support team at support@snapstream.com or for more info on how to reach us -- https://www.snapstream.com/support
Posted Dec 19, 2019 - 12:49 CST
Monitoring
We have idenified the issue that is impacting mail delivery as our provider is experiencing a major outage. Notifications should start to arrive in next few minutes as this is being resolved. We will update soon once this is fully resolved.

Thank You
Posted Dec 19, 2019 - 12:46 CST
Investigating
We are currently working to resolve this issue.
Posted Dec 19, 2019 - 11:58 CST
This incident affected: SnapStream Email Alerts.